A N Z E I G E

Open Office Calc: Dynamische Diagramme

  • Eine kleine Frage zu Calc. Gibt es eine Möglichkeit dynamische Diagramme zu erstellen (möglichst ohne Makros)? Das einzige was sich in der Hilfe dazu findet ist: "NeoOffice Calc ermöglicht die Darstellung von Tabellendaten in dynamischen Diagrammen, die bei Änderung der Daten automatisch aktualisiert werden."


    Problemstellung:
    In der Spalte B sollen nacheinander beliebig viele Werte eingetragen werden, die in einem Diagramm dargestellt werden sollen.
    (Beispiel: Die Userzahlen des CyBoards werden einmal monatlich erfasst. In Spalte A stehen die Monate, in Spalte B die jeweilige Userzahl. Z.B. A1: Januar 2013, B1: 19413, A2: Februar 2013, B2: 19550, usw. Das Diagramm hat also im Juli den Datenbereich B1:B7. Wenn nun im August in der Zelle B8 der neue Wert eingetragen wird, soll das Diagramm automatisch um diesen ergänzt werden).


    Die theoretischen Möglichkeiten wäre, dass beim Diagramm automatisch Zellen ohne Wert nicht dargestellt werden (eine entsprechende Einstellmöglichkeit gibt es aber soweit ersichtlich nicht). Oder für das Diagramm einen dynamischer Datenbereich festlegen.


    Ist das irgendwie möglich?



    Mein Lösungsansatz:


    Die Definition eines dynmamischen Zellbereichs abhängig von der Anzahl der eingetragenen Werte über die Funktion Verschiebung.


    Im Beispiel wäre der Bereich:
    VERSCHIEBUNG($Tabelle1$B$1;0;0;ANZAHL2($B$1;$B$1000);1)


    Also Bereich mit Bezug auf B1 ohne Verschiebung mit Höhe bestimmt durch die Anzahl der eingetragenen Werte mit der ANZAHL2-Funktion.


    Das funktioniert so weit. Vergebe ich z.B. den Namen "Userzahlen" für den Bereich VERSCHIEBUNG($Tabelle1$B$1;0;0;ANZAHL2($B$1;$B$1000);1) gibt mir z.B. die Funktion =MAX(Userzahlen) immer den korrekten Höchstwert der irgendwo in Spalte B eingetragen wurde oder die Funktion =SUMME(Userzahlen) die korrekte Summe.



    Nur leider lässt nun die Diagrammfunktion den Datenbereich "Userzahlen" nicht zu. Ebensowenig den direkten Eintrag der Verschiebungs-Funktion oder überhaupt generell Formeln, sondern nur einen direkt eingegebenen Zellbereich.


    Gibt es irgendeine Möglichkeit einen benannten Bereich als Datenbereich für ein Diagramm anzugeben (oder einen indirekten Bezug mit Verschiebung o.ä.)?

  • A N Z E I G E

Jetzt mitmachen!

Du hast noch kein Benutzerkonto auf unserer Seite? Registriere dich kostenlos und nimm an unserer Community teil!

A N Z E I G E